ФорумСофт → VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT
2018-03-02 14:31:51
Вот такая ошибка

Raw-mode is unavailable courtesy of Hyper-V. (VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT)
вылазит при попытке запустить 32bit Linux Mint в VirtualBox на одной машинке…


Код ошибки: 

E_FAIL (0x80004005)
Компонент: 

ConsoleWrap
Интерфейс: 

IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT
2018-03-02 17:16:19
что-то типа того может быть поможет:
https://msdnshared.blob.core.windows.net/media/TNBlogsFS/prod.evol.blogs.technet.com/CommunityServer.Blogs.Components.WeblogFiles/00/00/00/48/12/6116.HVW8a.jpg
2018-03-02 19:50:40
f1af
Я так понимаю, тебе очень впадлу было скачать эту картинку и залить её на форум.
Лень достигла терминальной стадии, когда лишнее движение мышкой грозит нервным срывом.
Ничего страшного, я помогу тебе. Вот. Держи.

BIOS
2018-03-18 03:55:42
Форум виртуалбокса прям пестрит ответами.

Hi!
I am getting the following error, does anyone has an idea how to fix it?
Hyper-V is removed, VT-X should be enabled.


VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT

I'm afraid that Vagrant is not supported on these forums. If you can demonstrate the problem happening with a standard install then we can look at it a bit harder. For the moment I'd only suggest making 1000% sure that Hyper-v is disabled, then restart the host from a complete power down.

убиться об стену

Проблема вроде как популярная
If u get this error while booting virtual machine on Virtuabox
Raw-mode is unavailable courtesy of Hyper-V. (VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT).
Try to resolve by disable Hyper-V in Window 10


Все советуют отключить Hyper-V… но у меня просто руки не доходят до виндовой машины, чтобы проверить это.

Проблема
Raw-mode is unavailable courtesy of Hyper-V.
(VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT).

Решение
Отключить компонент Windows - Hyper-V
Панель управления -> Все элементы панели управления ->Программы и компоненты -> Включание или отключение компонентов Windows
2018-03-27 05:06:11
Problem

Raw-mode is unavailable courtesy of Hyper-V.
(VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT).

Solution

Disable the Windows component – Hyper-V

To disable Hyper-V in Windows Features
1. Open Windows Features.
2. Expand the Hyper-V sub-section.
3. Uncheck Hyper-V, click/tap on OK.
4. Restart the computer when prompted.

VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT

OR

In an elevated Command Prompt write this:
bcdedit /set hypervisorlaunchtype off


OR

In an Windows Power Shell write this:
Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All
2018-05-03 01:41:29
Just as I posted the above, I found the solution:
open an admin command prompt and run:

bcdedit /set hypervisorlaunchtype off

This seems to have resolved the problem
https://forums.virtualbox.org/viewtopic.php?p=417444

I've run this also from powershell to disable Hyper-V
Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All


I have a 64bit host, but can't install 64bit guests
In fact you can install 64bit guests on 32bit hosts, so the «bittedness» of the host OS is not the issue. The issue is that in VirtualBox, hardware support for virtualization (Intel VT-x or AMD-v) is required for certain VMs. This includes all 64bit VMs, regardless of the host.
To enable 64bit guests, run through the following checklist :-
  • 1. Note your exact CPU model or part number, then go online and check its capabilities. The CPU must have 64bit capability and support either Intel or AMD virtualization technologies: VT-x or AMD-v.

  • 2. You usually need to enable VT-x/AMD-v in the host PC BIOS. You need to check with your PC manual or support forum to find out how to boot into the BIOS screen. This is probably not something we here at the VirtualBox forums can help you with. Once you get there you need to look for something buried in a menu, perhaps in the security category. The option may be called something like «Enable Virtualization Technology». If you see «Virtual Directed I/O» (VT-d/AMD-Vi) then that is a different thing. Remember to reboot your host PC after making BIOS changes - in this case a full restart from power off is required, just resuming from a hibernated state may not do the job.

  • 3. If (1) and (2) are already taken care of, then make sure that no other host apps are already using VT-x/AMD-v. The usual culprits are system level debuggers, other VM platforms, and some resident anti-virus applications. This has become a particular issue with 64bit Windows desktop and server hosts - especially Win8/Win2k12/Win10, since these may enable Microsoft's Hyper-v VM platform by default: this grabs ownership of VT-x and won't play nice with VirtualBox.

  • 4. When creating a VM, make sure you choose the 64-bit version of the guest OS template in <VM Settings> | General | Basic | Version, e.g. choose «Ubuntu (64 bit)» and not «Ubuntu» or «Ubuntu (32bit)». This has become more important since VirtualBox 4.3.x, because choosing the correct template also allows other modern processor features to be visible to the guest - it's not just about 64bit capability any more.

Additional Notes for Windows Hosts
  • 1. To check the status of Hyper-v in Windows 10, <right click start> | Run | OptionalFeatures.exe, and look for the «Hyper-V» option. The box should be empty, not checked or shaded. If you want to be absolutely sure that Hyper-v is gone then open an administrator command console and type «bcdedit /set hypervisorlaunchtype off». Make sure to fully power down and reboot the host after changing the Hyper-v setting.

  • 2. On some Windows hosts with an EFI BIOS, DeviceGuard or CredentialGuard may be active by default, and interferes with OS level virtualization apps in the same way that Hyper-v does. These features need to be disabled. On Pro versions of Windows you can do this using gpedit.msc (set Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security to Disabled. CredentialGuard should be similar. On non-Pro version of Windows you'll need to Google for the equivalent registry hacks.
Нужно бежать со всех ног, чтобы только оставаться на месте, а чтобы куда-то попасть, надо бежать как минимум вдвое быстрее!